Search results

Migration of Custom Widgets from lower versions to v5.2.48 or later

When the Bold BI is upgraded from the lower version to v5.2.48 or later, custom widgets available in the Bold BI build will be upgraded automatically. To upgrade the custom widgets(created in the version lower than 5.2) which is placed manually in the below mentioned location after the v5.2.48 migration run the custom widget upgrader utility mentioned below:

  • Place the Custom Widgets as mentioned in the link.

  • Now run the custom widget upgrader utility by following the steps below:

    Environment Steps for running Utility
    Linux Navigate to the custom widget upgrader utility folder cd /var/www/bold-services/application/utilities/customwidgetupgrader/.
    Run the utility with the dotnet command /var/www/bold-services/dotnet/dotnet CustomWidgetUpgrader.dll.
    Windows Run the CustomWidgetUpgrader.exe which is available in the below location C:\BoldServices\utilities\customwidgetupgrader\.